Back
Maintenance

ssl certificate renewal

Completed 12 Feb at 09:45pm CET.

https://hergetto.live
Completed

Everything is working!

Posted 12 Feb at 09:45pm CET.
Updated

ssl certificate updated, we're checking if everything is working again

Posted 12 Feb at 09:43pm CET.
Started

We're gonna temporarily pause the website to refresh the ssl certificate

Posted 12 Feb at 09:33pm CET.